Announcement

Collapse
No announcement yet.

List panel displays html code when Roles field is enabled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • List panel displays html code when Roles field is enabled

    Hi,

    I defined Roles as one of the fields to displayed in the List Layout for Users entity, If no roles are defined for the user, it shows "none" but i when define a role for the user it displays the html code instead of the role. See attachment.


    Click image for larger version

Name:	Screenshot_4.png
Views:	46
Size:	31.9 KB
ID:	87434

  • #2
    How to reproduce? I think u have some modifications on your crm or 3rd party extensions
    Software Engineering, working with Espocrm since 2014
    CEO @ Eblasoft Ltd.
    Contact Me

    Comment


    • murugappan
      murugappan commented
      Editing a comment
      Hi, Thank you for responding.

      There are no modification to the software. We have not installed any third-party extensions or made any mods of our own. We always use the software as is.

      With regards to problem. Its simple to reproduce. Just go to adminstration->users->layout->list. Then define "roles" as on of the fields to display. Create a user with a specific role. Then display the users list again. That's it.

      Btw, we were looking into the extension produced by you Company as rfecommend by Abdulkadir. Unfortunately your site is not showing a complete picture. Example: I dont see any themes. Moreover, some of the extension seem overpriced to see the cost-benefit. Meaning, we think we could do without the at the price as we have developed our own front using Vuejs and Vuetify. We use Espocrm UI to implement the back-end administration - headless CMS.

  • #3
    Originally posted by murugappan View Post
    Hi,

    I defined Roles as one of the fields to displayed in the List Layout for Users entity, If no roles are defined for the user, it shows "none" but i when define a role for the user it displays the html code instead of the role. See attachment.


    Click image for larger version

Name:	Screenshot_4.png
Views:	46
Size:	31.9 KB
ID:	87434
    That is a known issue, all you need to do is to uncheck (link) on the fields roles. hence all links are displayed as link by default but if you check link then it expose the html link. So just to go user/list -> roles and uncheck Link option.

    Comment


    • murugappan
      murugappan commented
      Editing a comment
      @rabil thank you so much. It worked.
Working...
X