Announcement

Collapse
No announcement yet.

EspoCRM 7.1.0 released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EspoCRM 7.1.0 released

    Compatibility:
    • Added PHP 8.1 support #2211
    • Dropped PHP 7.3 support #2168

    Enhancements:
    • Dark theme #2185
    • Formula sandbox #2201
    • Access info email without password #2213
    • Ability to send a password change link to a specific user #2215
    • Formula: Array functions indexOf, removeAt, unique #2256
    • Formula: json\encode function #2233
    • Formula: Object functions #2232
    • Formula: Null coalescing operator #2230
    • Formula: number\parseInt and number\parseFloat functions #2229
    • Formula: string\split function #2227

    Improvements:
    • Export in idle #2197
    • Mass action processing in idle #2186
    • Mass Email: Supporting custom entity types as recipients #2203
    • Using CSS variables for colors #2184
    • Emails: Relationship with Tasks #2272
    • Formula: Check syntax button #2199
    • Config parameter 'Records per page (Select)' #2277
    • Utilizing full-text search in link fields autocomplete and email address lookup #2278
    • Showing own user as a suggestion for assigned user field if input is empty #2281
    • Own user at first position in list when selecting user #2275
    • Image preview: Ability to switch images with arrow keys #2271
    • Ability to export/import roles #2262
    • Error messages not closing automatically #2259
    • Float field: Decimal Places parameter #2225
    • Meetings/Calls: Duplicate action from modal view #2224
    • Currency field: Ability to disable currency conversion for a specific field #2223
    • Ability to collapse Compose Email modal #2222
    • Wysiwyg field: Supporting image paste from clipboard #2190
    • Ability to run Espo in non-developer-mode right from repository #2254

    Codebase:
    All issues: https://github.com/espocrm/espocrm/m...e/130?closed=1

  • #2
    Congratulations for this new release

    Weren't translations supposed to be updated in every major releases?

    I updated the Italian translation in POEditor but the changes aren't in this version.

    Comment


    • yuri
      yuri commented
      Editing a comment
      I will apply translation in a hotfix release. BTW 7.1 is a minor. There are plenty of new labels in 7.1. So they missing translation now.

  • #3
    Congratulations for the new release.

    Thank you so much yuri for all the work you put in. looking forward to enjoy the new functions.

    Big thanks for such powerful software.

    Comment


    • #4
      Fantastic release. Is there any database table updates in this release? We need this info so that we can schedule downtimes in production. Our database is 15GB and can take long upgrade time frame. Appreciate your advise. Thank you.

      Btw, i have posted the migration strategy and plan for those who want to upgrade from 5.7.11 to 7.0.9 in another post. Please help yourselves to it. Gladly help anyone who needs assistance.
      Last edited by murugappan; 04-22-2022, 04:01 AM.

      Comment


      • espcrm
        espcrm commented
        Editing a comment
        Kindly share links as I'm been aware and not active on forum. Thanks.

    • #5
      Hi

      The version 7.1.1 upgrade which is already version 7.1.0 is generating the "package archive does not exist error". Please see the attached screen cap. However the upgrade goes through and the instance seems to be working fine thus far. I am not sure if this is a critical problem. However, the upgrade from 7.0.9 does not have any problem.

      Click image for larger version  Name:	Upgrade711.png Views:	0 Size:	33.7 KB ID:	80043 Please help.

      Comment


      • #6
        I just ran the update to 7.1.1 and got the same thing:

        sudo -u www-data php command.php upgrade

        Current version is 7.1.0.
        EspoCRM will be upgraded to version 7.1.1 now. Enter [Y] to continue.
        Y
        This may take a while. Do not close the terminal.
        Downloading...
        Upgrading...
        Initialization...
        Copying before upgrade files...
        Rebuilding...
        Before upgrade script execution...
        Rebuilding...
        Copying files...
        Rebuilding...
        Copying after upgrade files...
        Rebuilding...
        After upgrade script execution...
        Rebuilding...
        Finalization...
        Initialization...
        Reverting...
        Package Archive doesn't exist.

        Like the above post says, it looks as if the update finished ok. The new version works fine as far as I can tell but have not tested it completely.

        I updated my 'backup' version of EspoCRM. I'll wait until I hear back from the community or developers before I update my production version.

        Comment


        • #7
          I don't know why these mysterious messages are displayed. We will investigate it. I just tested the upgrade, got same messages.

          Edit. Actually. files correspond to v7.1.0. So it's reverted.
          Last edited by yuri; 04-23-2022, 06:33 PM.

          Comment


          • #8
            Edit. Actually. files correspond to v7.1.0. So it's reverted.
            So you are saying the update did not 'take' and that everything is now as it was before the update?

            Comment


            • yuri
              yuri commented
              Editing a comment
              Yes. The next upgrade package will handle it. You can change the version back to 7.1.0 in the data/config.

              To upgrade w/o the error, try running the upgrade command with -s parameter. It will run in a single process, the error won't occur.

          • #9
            I change the data/config and I ran with -s and still got the messages.

            $ sudo -u www-data php command.php upgrade -s


            Current version is 7.1.0.
            EspoCRM will be upgraded to version 7.1.1 now. Enter [Y] to continue.
            Y
            This may take a while. Do not close the terminal.
            Downloading...
            Upgrading...
            Initialization...
            Copying before upgrade files...
            Rebuilding...
            Before upgrade script execution...
            Rebuilding...
            Copying files...
            Rebuilding...
            Copying after upgrade files...
            Rebuilding...
            After upgrade script execution...
            Rebuilding...
            Finalization...
            Upgrade is complete. Current version is 7.1.1.
            You have the latest version.

            Did the update actually happen or did it not. It says 7.1.1 in the "About" screen but did the files get updated?

            Comment


            • yuri
              yuri commented
              Editing a comment
              Upgrade from 7.0.9 to 7.1.0 or upgrade from 7.0.9 to 7.1.1 went through. The only upgrade affected is from 7.1.0 to 7.1.1.

              Displaying upgrade steps is a new improvement: https://github.com/espocrm/espocrm/issues/2234

              Too many questions for me. Most are already answered here. Please spare me.

            • dev77
              dev77 commented
              Editing a comment
              OK. so if there is no message saying:

              Reverting...
              Package Archive doesn't exist.

              .. then the update went through.

              Should we continue to use the "-s" ?

            • yuri
              yuri commented
              Editing a comment
              "-s" only needed for 7.1.0->7.1.1 and 7.1.*->7.1.2 (not released yet, the message will be displayed in the terminal, so no need to remember about this).

          • #10
            I have upgraded all our development instances to 7.1.2. Everything is good. Will soon upgrade the production instances when downtime available.

            Fantastic, good work.

            Comment


            • paul
              paul commented
              Editing a comment
              @dev77: You can install Espo (or other software) as a "development instance" to check new updates or develop own extensions without "playing" on the "productive instance". If you don't find any bugs or your extension is ready, then you can install it on the "production instance". So, both are normal installations of Espo, but only in the "production instance" you store your data an so on. I hope I could explain it understandable

            • dev77
              dev77 commented
              Editing a comment
              I have two Linode instances both using Ubuntu 20.04... one is a small test server and the other is my large production server. I've installed Espo on my test server and added one record to it in order to test it with PHP 8.0. is that what you would call a "development instance?"

              I thought a dev. instance might be a different download version.

            • paul
              paul commented
              Editing a comment
              In my opinion it is a development instance. Because you are checking things before installing it on the productive instance.

          • #11
            Hi dev77 paul

            We have installed a copy of the production instance in the following environment:

            (1) "dev" - DEVELOPMENT which is used to enhance the existing production copy for new requirements. This is where we upgrade and test all our enhancements.
            (2) "tst" - TESTING which is used to migrate from "dev" so that the users can test the changes
            (3) "stg" - STAGING which is used to migrate from "tst" and kept there until we can get a suitable time to down the "prd" environment (see next) and migrate the changes to the production version.
            (4) "prd" - PRODUCTION which is used for production-approved version to be used in "live" (or public) use.
            (5) "vnl" - VANILLA which holds a copy of the dev,tst,stg or prd version at any one time to test php or mariadb upgrade.

            How we do this is:
            (1) We set up to two servers (with our hosting provider) - say "Server1" and "Server2"
            (2) Server1 is a dedicated server containing only the "prd" version of the instance and is usually a high capacity server. In this server we can create multiple accounts for different app instances. Example: Server1 may contain "marketingcrm" under account "marketing.company.com" and another instance "supportcrm" under account "support.company.com".
            (3) Server2 may be a dedicated server or vps server (suggested as is cheaper) with the same capacity. This server contains "dev.company.com", "tst.company.com", "stg.company.com", "vnl.company.com" accounts. Unders these accounts, the related instances can loaded, developed and tested.

            I hope this helps.
            Last edited by murugappan; 05-04-2022, 10:14 AM.

            Comment


            • #12
              Hi

              Since version 7.0.9, now upgraded to 7.1.3 we have been getting the following error in the logs:
              "ERROR: 405 Method Not Allowed Type: Slim\Exception\HttpMethodNotAllowedException Code: 405 Message: Method not allowed. Must be one of: GET, POST, PUT, DELETE File: /home/dmsemastpa/public_html/emasdms/vendor/slim/slim/Slim/Middleware/RoutingMiddleware.php Line: 94 Trace: #0 /home/dmsemastpa/public_html/emasdms/vendor/slim/slim/Slim/Middleware/RoutingMiddleware.php(58):"

              We waited after installing upgrade 7.1.3 but the problem is still persisting (error log attached). It does not seem to have any impact as yet but we need to eliminate the error before any significant impact occurs. Appreciate any help
              Attached Files

              Comment


              • yuri
                yuri commented
                Editing a comment
                Maybe you have API requests being made to your Espo with non-allowed methods?

                We upgraded the Slim library in v7.0 that's must be the cause why errors started to occur.

              • murugappan
                murugappan commented
                Editing a comment
                Hi Yuri,

                Yes we are using some apis. Will the api documentation show the latest methods?

            • #13
              Since we updated 7.09 -> 7.1.3 the cron jobs are not working anymore.
              https://URL#Admin/jobs also no activity.

              Anyone else with this problem?

              Comment


              • Paulina
                Paulina commented
                Editing a comment
                Same issue. Did you find any solution?

              • murugappan
                murugappan commented
                Editing a comment
                Paulina and @LexD

                (1) Have you checked the espocrm logs? What message do you get?
                (2) Did you switch to different version of PHP? Example. From PHP 7.3 to 7.4 or 7.4 to 8.0?

              • Paulina
                Paulina commented
                Editing a comment
                murugappan
                1. Logs says nothing
                2. Not yet, will try
            Working...
            X