Had the same issue as topic starter and your answer helped me to solve the problem. I just deleted all SMTP settings i could in my profile and everything...