Announcement

Collapse
No announcement yet.

Black square instead of photos

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black square instead of photos

    Hello!
    I have this problem:
    When you attach a photo from your phone (android) Some photos appear as a black square. Some photos are downloaded as they should.

  • #2
    Hello
    How often does it happen?
    Maybe problem is with internet connection or something like this... I've never faced it.

    Comment


    • #3
      Originally posted by tanya View Post
      Hello
      How often does it happen?
      Maybe problem is with internet connection or something like this... I've never faced it.
      I can not say exactly. We used to not upload pictures using the phone.
      Now it happens frequently when downloading from the phone.
      I do not think that this is the fault of the internet connection.
      There is another oddity, some photos are flipped after the download.. In the gallery of my phone these photos are displayed without turning. Perhaps this is related to the data that was saved during the shooting.
      Tell me please where is the piece of code that is responsible for this (upload, rotate photos)
      Last edited by mr2d2; 10-13-2017, 10:20 AM.

      Comment


      • #4
        client/src/views/fields/attachment-multiple.js

        Comment


        • #5
          Originally posted by tanya View Post
          client/src/views/fields/attachment-multiple.js
          thank!
          Do you have any idea why black photos are uploaded?

          Comment


          • #6
            not yet...
            needs debugging

            Comment


            • #7
              Originally posted by mr2d2 View Post
              ...some photos are flipped after the download.. In the gallery of my phone these photos are displayed without turning.
              I think espo doesn't handle the EXIF orientation of uploaded photos. So if your're using your smartphone to upload pictures they might appear rotated yb 90 degrees. See https://www.sanwebe.com/2012/05/fix-...-its-exif-data

              Comment

              Working...
              X