Announcement

Collapse
No announcement yet.

Time format in Settings not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Time format in Settings not working

    Hi,
    Time format in settings not working for users. Only preferences works.
    I need to set the time format for all users by administrator.
    Please help.


  • #2
    Hello
    Global time format works, but if user doesn't set time format in own preferences.... The priority of preferences is higher

    Comment


    • #3
      Hi,

      User didn't set any preference. So he should have the time format preferences set by administrator in settings ryt?
      It is not working.

      Please help

      Comment


      • #4
        go to data/preferences/ and check, if file with userId exists. If yes, user sets own preferences.
        Also you can go to user's profile > preferences > reset button - all preferences will be set to default

        Comment


        • #5
          Hi,
          No preference file for the user and I tried reset preferences also. Not worked.

          I tried with downloading new espocrm and logged in as admin

          1. Set time format in administrator preferences as 24 hour
          2. Set settings time format as 12 hour

          Then logged in as user. Checked calendar timing , and it was 24 hour. It should be 12 hour ryt? no preference set by user.

          Comment


          • #6
            Can't reproduce on the demo. Attach screenshots. please.

            Comment


            • #7
              Hi Tanya,

              I commented the lines which was overwriting the settings with preference value in date-time.js.

              Now it is working fine.

              Thanks tanya.

              Comment

              Working...
              X