Announcement

Collapse
No announcement yet.

Permission error while upgrading 4.6.0 to 4.7.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Permission error while upgrading 4.6.0 to 4.7.1

    During upgrade from 4.6.0 to 4.7.1 there is this error
    Code:
    [2017-05-29 11:15:33] Espo.ERROR: API [POST]:/:controller/action/:action, Params:Array ( [controller] => Admin [action] => runUpgrade ) , InputData: {"id":"592c02d34418b"} - Permission denied for <br>tests/unit/Espo/Core/SelectManagers/Base.php [] []
    [2017-05-29 11:15:33] Espo.ERROR: Display Error: Permission denied for <br>tests/unit/Espo/Core/SelectManagers/Base.php, Code: 500 URL: /api/v1/Admin/action/runUpgrade [] []
    [2017-05-29 11:16:23] Espo.ERROR: Uncaught Exception Error: "Call to undefined method Espo\Hooks\Common\NextNumber::afterSave()" at /application/Espo/Core/HookManager.php line 122 {"exception":"[object] (Error(code: 0): Call to undefined method Espo\\Hooks\\Common\\NextNumber::afterSave() at /application/Espo/Core/HookManager.php:122)"} []
    [2017-05-29 11:18:04] Espo.ERROR: API [POST]:/:controller/action/:action, Params:Array ( [controller] => Admin [action] => runUpgrade ) , InputData: {"id":"592c036a6460e"} - Permission denied for <br>tests/unit/Espo/Core/SelectManagers/Base.php [] []
    [2017-05-29 11:18:04] Espo.ERROR: Display Error: Permission denied for <br>tests/unit/Espo/Core/SelectManagers/Base.php, Code: 500 URL: /api/v1/Admin/action/runUpgrade [] []
    [2017-05-29 11:21:23] Espo.ERROR: Uncaught Exception Error: "Call to undefined method Espo\Hooks\Common\NextNumber::afterSave()" at /application/Espo/Core/HookManager.php line 122 {"exception":"[object] (Error(code: 0): Call to undefined method Espo\\Hooks\\Common\\NextNumber::afterSave() at /application/Espo/Core/HookManager.php:122)"} []
    Before this I made upgrade 4.5.0 to 4.5.1 and 4.5.1 to 4.6.0 without any problems.

  • #2
    Hello
    Check permission to 'tests' folder, please. And rebuild EspoCRM

    Comment


    • #3
      there is no "tests" folder, these are the folders in root of EspoCRM folder:
      Code:
      api
      application
      client
      custom
      data
      html
      install
      portal
      vendor
      Also I do not understand what you mean by "rebuild EspoCRM"...
      I'm using upgrade packages from https://www.espocrm.com/download/upgrades/


      Comment


      • #4
        Code:
         
         [2017-05-29 11:21:23] Espo.ERROR: Uncaught Exception Error: "Call to undefined method Espo\Hooks\Common\NextNumber::afterSave()" at /application/Espo/Core/HookManager.php line 122 {"exception":"[object] (Error(code: 0): Call to undefined method Espo\\Hooks\\Common\\NextNumber::afterSave() at /application/Espo/Core/HookManager.php:122)"} []
        Administration > Rebuild or run rebuild.php from your EspoCRM dirictory. This error will be fixed. After success upgrade it runs automatically.

        Upgrade file was updated. If your instance wasn't updgraded, download it again and use this archive

        Comment


        • #5
          I downloaded EspoCRM-upgrade-4.6.0-to-4.7.1.zip again and update is now complete. Thanks for quick fix

          Comment


          • #6
            Hm, I still see this error after rebuild
            Code:
            [2017-05-29 14:31:30] Espo.ERROR: Uncaught Exception Error: "Call to undefined method Espo\Hooks\Common\NextNumber::afterSave()" at /application/Espo/Core/HookManager.php line 122 {"exception":"[object] (Error(code: 0): Call to undefined method Espo\\Hooks\\Common\\NextNumber::afterSave() at /application/Espo/Core/HookManager.php:122)"} []
            seems to happen every 5 minutes which is the cronjob

            Comment


            • #7
              Attach, please, data/cache/application/hooks.php

              Comment


              • #8
                Did you try to clear cache again. If there any error in log right after clearing cache.


                Thanks

                Comment


                • #9
                  Originally posted by tanya View Post
                  Attach, please, data/cache/application/hooks.php
                  see attachment on this post (upload .php not possible, so I added as .zip)

                  Originally posted by yurikuzn View Post
                  Did you try to clear cache again. If there any error in log right after clearing cache.
                  I started rebuild function now and there are no errors in log. I also did the same thing yesterday after update.

                  The only thing I noted is that timestamp in logfile is not in correct time zone - please fix if possible, thanks.
                  Attached Files

                  Comment


                  • #10
                    The problems seems was with php cache.

                    Comment


                    • #11
                      We will not fix timestamp in log. It's UTC.

                      Comment


                      • #12
                        Originally posted by yurikuzn View Post
                        The problems seems was with php cache.
                        Did you find and fix this error?
                        I just read your instructions again. I understood them as "click rebuild and see if this click causes any errors" but you meant "click rebuild and it should solve error", correct? In the logfiles the error is still there.

                        Originally posted by yurikuzn View Post
                        We will not fix timestamp in log. It's UTC.
                        ok

                        Comment


                        • #13
                          Ok, I cleared browser cache and PHP Opcache (as far as I know both should not be necessary) and now I cannot login
                          Error "bad server response" - but there are no errors in log and also not in Apache log
                          The only thing I found is in javascript console "unreachable code after return statement - espo.min.js:206:12"

                          Comment


                          • #14
                            Please help, thanks!

                            Comment


                            • #15
                              How? Without error... Possible you forget password. (but you will get another error)
                              You could try to install new EspoCRM just to check if everything is ok with server configurations.

                              Comment

                              Working...
                              X